Which ruby version can be used with current rails versions?

Rails Version Ruby min. Ruby recommended
3.2 1.8.71 1.9.3, supports 2.0 2
4.0 1.9.3 2.0.0 3
4.1 1.9.3 2.1.0 4
4.2 1.9.3 2.1.0 5
5.0 2.2.0 2.2.0+ 6

Sources: